Exception being thrown while executing PackInstaller.exe

Topics: User Forum
Nov 6, 2006 at 5:03 PM
Every time I run PackInstaller.exe (from the latest build) I get the exception shown below. I am running Windows Server 2003 with .NET 2.0 installed. Is there anything I need to do in order to get it up and running?

Thanks,
George Jordanov Ivanov


---------------------------------->
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

                            • Exception Text **************
System.Data.ConstraintException: Failed to enable constraints. One or more rows contain values violating non-null, unique, or foreign-key constraints.
at System.Data.DataSet.FailedEnableConstraints()
at System.Data.DataSet.EnableConstraints()
at System.Data.DataSet.set_EnforceConstraints(Boolean value)
at System.Data.XmlDataLoader.LoadData(XmlReader reader)
at System.Data.DataSet.ReadXml(XmlReader reader, Boolean denyResolving)
at System.Data.DataSet.ReadXml(String fileName)
at Microsoft.VSPowerToys.PackInstaller.PackInstallerForm.LoadPackFeed()
at Microsoft.VSPowerToys.PackInstaller.PackInstallerForm.mgr_TaskCompleted(Object sender, TaskCompletedEventArgs e)


                            • Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
PackInstaller
Assembly Version: 0.9.0.0
Win32 Version: 0.9.0.0
CodeBase: file:///C:/Pack_Installer/PackInstaller.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GACMSIL/System.Windows.Forms/2.0.0.0_b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GACMSIL/System/2.0.0.0_b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GACMSIL/System.Drawing/2.0.0.0_b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Data
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GAC32/System.Data/2.0.0.0_b77a5c561934e089/System.Data.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GACMSIL/System.Xml/2.0.0.0_b77a5c561934e089/System.Xml.dll
----------------------------------------
TaskManager
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Pack_Installer/TaskManager.DLL
----------------------------------------
System.Deployment
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GACMSIL/System.Deployment/2.0.0.0_b03f5f7f11d50a3a/System.Deployment.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINNT/assembly/GACMSIL/System.Configuration/2.0.0.0_b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
Microsoft.JScript
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.42
CodeBase: file:///C:/WINNT/assembly/GACMSIL/Microsoft.JScript/8.0.0.0_b03f5f7f11d50a3a/Microsoft.JScript.dll
----------------------------------------

                            • JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Nov 7, 2006 at 11:25 AM
Me too. I'm running Windows XP. I already have some power toys installed: could that be the problem?
Coordinator
Nov 8, 2006 at 9:40 PM
The Beta version should work fine as far as I know. I posted on the main page what I think is the problem, and it's that I broke the Alpha when I released the Beta. I moved the Alpha to the Archived Releases sections to help point people properly to the latest version. If you can confirm for me that the PackInstallerBeta.exe throws the same error message, I'll be more than happy to keep debugging and see what I can find.